Sabtu, 22 November 2008

Legacy VLAN with GNS3

ya setelah lama ga posting sekarang saatnya aktif nulis lagi

kali ini enaknya bikin topik cara bikin Legacy VLAN di cisco. tapi bukan cisco hardware beneran tapi pake GNS3

mari kita lihat contoh topologi sederhana yang saya buat

router R1 dan router R2 dihubungkan dengan frame relay network
R1 terhubung ke port 1 framerelay switch dengan DLCI 101 dan R2 terhubung ke port 2 DLCI 201

routing protokol yang digunakan adalah ospf

berikut dibawah ini konfigurasinya

untuk konfigurasi file legacy_VLAN.net nya

autostart = False
[localhost:7200]
workingdir = E:\New Folder
[[2621]]
image = E:\ios\c2600-ik9s-mz.122-40a.BIN
idlepc = 0x80342788
ghostios = True
chassis = 2621
[[3640]]
image = E:\ios\c3640-is-mz.124-16.BIN
idlepc = 0x604a3f2c
ghostios = True
chassis = 3640
[[ROUTER R1]]
model = 2621
console = 2037
s0/0 = FR0 1
f0/0 = SW1 f0/1
[[ROUTER R2]]
model = 2621
console = 2038
s0/0 = FR0 2
f0/0 = SW3 f0/1
[[FRSW FR0]]
1:101 = 2:201
2:201 = 1:101
[[ROUTER SW1]]
model = 3640
console = 2034
slot0 = NM-16ESW
f0/1 = R1 f0/0
f0/4 = PC2 f0/0
f0/7 = PC1 f0
f0/13 = SW2 f0/13
[[ROUTER SW3]]
model = 3640
console = 2036
slot0 = NM-16ESW
f0/1 = R2 f0/0
f0/3 = PC5 f0/0
[[ROUTER SW2]]
model = 3640
console = 2035
slot0 = NM-16ESW
f0/4 = PC4 f0
f0/7 = PC3 f0/0
f0/13 = SW1 f0/13

[localhost:7201]
workingdir = E:\New Folder
udp = 10100
[[2621]]
image = E:\ios\c2600-ik9s-mz.122-40a.BIN
idlepc = 0x803f4dc0
ghostios = True
chassis = 2621
[[1710]]
image = E:\ios\C1700-K2.BIN
ram = 32
ghostios = True
idlepc = 0x8016f138
chassis = 1710
[[ROUTER PC2]]
model = 2621
console = 2041
idlepc = 0x80342788
f0/0 = SW1 f0/4
[[ROUTER PC3]]
model = 2621
console = 2042
idlepc = 0x80342788
f0/0 = SW2 f0/7
[[ROUTER PC1]]
model = 1710
console = 2045
f0 = SW1 f0/7
[[ROUTER PC4]]
model = 1710
console = 2046
f0 = SW2 f0/4
[[ROUTER PC5]]
model = 2621
console = 2022
f0/0 = SW3 f0/3

file SW1.cfg

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
!
!
!
interface FastEthernet0/0
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport access vlan 10
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
switchport access vlan 15
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
switchport mode trunk
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
no ip address
!
ip http server
!

!
control-plane
!
!
alias exec c conf t
alias exec s sh ip int br
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end

file SW2.cfg

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
interface FastEthernet0/0
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
switchport access vlan 10
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
switchport access vlan 15
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
switchport mode trunk
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface Vlan1
no ip address
!
ip http server
!
!
control-plane
!
!
alias exec c conf t
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
!
end


file R1.cfg


!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
memory-size iomem 15
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.129
ip dhcp excluded-address 192.168.3.1 192.168.3.129
!
ip dhcp pool 1
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
!
ip dhcp pool 2
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
!
!
call rsvp-sync
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.15
encapsulation dot1Q 15
ip address 192.168.3.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
!
interface Serial0/0.101 point-to-point
ip address 10.10.7.1 255.255.255.0
no arp frame-relay
frame-relay interface-dlci 101
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.10.7.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 1
network 192.168.3.0 0.0.0.255 area 1
!
ip classless
ip http server
!
!
dial-peer cor custom
!
!
alias exec c conf t
alias exec s sh ip int br
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
end


konfigurasi router R2 file R2.cfg

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
memory-size iomem 15
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.4.1 192.168.4.129
!
ip dhcp pool 3
network 192.168.4.0 255.255.255.0
default-router 192.168.4.1
!
!
call rsvp-sync
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.4.1 255.255.255.0
!
interface Serial0/0
bandwidth 512000
no ip address
encapsulation frame-relay
clock rate 512000
!
interface Serial0/0.201 point-to-point
ip address 10.10.7.2 255.255.255.0
no arp frame-relay
frame-relay interface-dlci 201
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router ospf 1
log-adjacency-changes
network 10.10.7.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 1
!
ip classless
ip http server
!
!
dial-peer cor custom
!
!
alias exec c conf t
alias exec s sh ip int br
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
!
end

untuk konfigurasi Switch 3 sama dengan konfigurasi Switch 1 da Switch 2

sedangkan untuk User2nya menggunakan konfigurasi ip dhcp
pada testing di atas Cisco 1700 tidak bisa dikonfigurasi ip dhcp nya

PC1#(config)int f0/0
PC1#(config-if)ip address dhcp
PC1#(config-if)no shut


Tidak ada komentar: